Why does m2e add dependency always zero

When I try to add a dependency in pom.xml, the result always zero. Like, I input "log4j", the select dependency UI show results for 'log4j' (0) How can I search the result from the central repository? This is my settings.xml:

<?xml version="1.0" encoding="UTF-8"?>
<settings
  xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <localRepository>G:/Maven/repository</localRepository>
  <pluginGroups>
  </pluginGroups>

  <proxies>
  </proxies>
  <servers>
  </servers>

  <mirrors>
  </mirrors>


  <profiles>
  </profiles>

</settings>

Answers


Why not using just as simple as possible:

<?xml version="1.0" encoding="UTF-8"?>
<settings
  xmlns="http://maven.apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <localRepository>G:/Maven/repository</localRepository>
</settings>

Need Your Help

Nokia Imaging SDK problems with EditingSession Class

c# visual-studio windows-phone-8 nokia-imaging-sdk lumia-imaging-sdk

I am trying to learn the Nokia Imaging SDK by going through the examples at developer.nokia.com and several other sites.

How Angular routes URLs like api?id=1&id=2?

angularjs ngroute

I am new to ng-route. I have a site called www.foo.com. And I just want to assign the template HTML (fooapi.view.html) and the controller (fooapi.controller.js) to the URLs like