Launch4j maven plugin will not work on 64-bit linux machine

I am trying to use the maven Launch4j plugin version 1.5.0.1

When I build the pom on my windows box, there is no issue (my windows box has both 32-bit and 64-bit versions of Java installed). But when I build the pom on my linux box, I get this issue:

Stack trace: org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.bluestemsoftware.open.maven.plugin:launch4j-plugin:1.5.01.1..... Failed to build executable; please verify your configuration

Cause by: net.sf.launch4j.BuilderException: net.sf.launch4j.ExecException: java.io.IOException: Cannot run program "/home/hudson/.m2/repository/org/bluestemsoftware/open/maven/plugin/launch4j-plugin/1.5.0.1/launch4j-plugin-1.5.0.1-workdir-linux/bin/windres": java.IOException: error=2, No such file or directory

I did quite a bit of digging around and I found this:

http://alakai.org:8088/browse/LAUNCHPLUGIN-15

But, the task is still open, so I can only assume that there is no fix in place for this issue on a 64-bit Linux OS that uses 64-bit java. Unfortunately, my linux box cannot access an external network, so installing 32-bit java is not much of an option. Does anyone know of any other possible work-arounds?

Answers


Just install ia32-libs for your distrib. On my ubuntu machine: sudo apt-get install ia32-libs


On recent x64 Ubuntu distributions (starting 14.04 LTS, tested on 16.04 LTS), do this:

$ sudo dpkg --add-architecture i386
$ sudo apt-get update
$ sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0:i386

For Fedora, install the 32 bit version of openjdk-devel. java-1.6.0-openjdk-devel.i686 or java-1.7.0-openjdk-devel.i686.

yum install java-1.6.0-openjdk-devel.i686

... or ...

yum install java-1.7.0-openjdk-devel.i686

Use yumdownloader on a different machine if you can not reach the network.


Need Your Help

How to change letter spacing of UIButton in Swift?

swift uibutton letter-spacing

I've found how to set letter spacing to UILabel (here) but this method is not working for UIButtons. Does anyone know how to do it?

How to add a new icons font like FontAwesome?

icons sencha-touch sencha-touch-2 font-awesome sencha-architect

I've been using Sencha Touch for a long time and now I'm trying Sencha Architect. I need to include FontAwesome to use more icons in my buttons. The problem is that I don't know where I have to wri...