Schema information for Entity Framework not found

When I open the web.config file in my ASP.NET web application, some messages are displayed in the error list:

Meldung 1   Die Schemainformationen für das Element 'entityFramework' konnten nicht gefunden werden.
Meldung 2   Die Schemainformationen für das Element 'defaultConnectionFactory' konnten nicht gefunden werden.
Meldung 3   Die Schemainformationen für das Attribut 'type' konnten nicht gefunden werden.
Meldung 4   Die Schemainformationen für das Element 'parameters' konnten nicht gefunden werden.
Meldung 5   Die Schemainformationen für das Element 'parameter' konnten nicht gefunden werden.
Meldung 6   Die Schemainformationen für das Attribut 'value' konnten nicht gefunden werden.

So Visual Studio seems to be unable to find the schema information for the Entity Framework, the other messages are caused by this issue.

My web.config-file looks like this:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  [...]
  <entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework">
      <parameters>
        <parameter value="Data Source=.\SQLEXPRESS; Integrated Security=True; MultipleActiveResultSets=True" />
      </parameters>
    </defaultConnectionFactory>
  </entityFramework>
</configuration>

Where can I find the necessary schema information file?

Answers


An updated XSD will be included with Visual Studio 2012. In the meantime the messages should not affect either compilation or use of the config file and should go away when the file is not open in the editor.


Need Your Help

Can firebug or developer tools use to hack a web site?

javascript jquery html

I was facing to an interesting issue when implementing some role specific feature in a web site.