OpenAM With Maven

I am trying to download OpenAM through Maven dependencies as stated on this website:

https://wikis.forgerock.org/confluence/display/openam/Using+Maven+and+OpenAM

Below is Maven pom.xml file:

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven 4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>

  <groupId>com.example</groupId>
  <artifactId>OpenAMExample</artifactId>
  <version>0.0.1-SNAPSHOT</version>
  <packaging>jar</packaging>

  <name>OpenAMExample</name>

  <properties>
     <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
     <openam.version>10.1.0-Xpress</openam.version>
  </properties> 

  <dependencies>
<dependency>
    <groupId>org.forgerock.openam</groupId>
    <artifactId>openam-core</artifactId>
    <version>${openam.version}</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.forgerock.openam</groupId>
    <artifactId>openam-shared</artifactId>
    <version>${openam.version}</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.forgerock.openam</groupId>
    <artifactId>openam-federation-library</artifactId>
    <version>${openam.version}</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.forgerock.openam</groupId>
    <artifactId>openam-clientsdk</artifactId>
    <version>${openam.version}</version>
    <scope>provided</scope>
</dependency>
      <dependency>
          <groupId>junit</groupId>
          <artifactId>junit</artifactId>
          <version>3.8.1</version>
          <scope>test</scope>
      </dependency>
     </dependencies>

  <repositories>
<repository>
    <id>forgerock</id>
    <url>http://maven.forgerock.org/repo/releases</url>
</repository>
  </repositories>
</project>

I cannot download this, there seems to be problems. It mentions missing artifact for each artifact within OpenAM.

Having researched on Google no one seems to have any problems.

Any ideas why?

EDIT

BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.305s
[INFO] Finished at: Mon Aug 05 16:01:44 BST 2013
[INFO] Final Memory: 2M/15M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project OpenAMExample: Could not resolve dependencies for project com.webchannel.example:OpenAMExample:jar:0.0.1-SNAPSHOT: The following artifacts could not be resolved: org.forgerock.openam:openam-core:jar:10.1.0-Xpress, org.forgerock.openam:openam-shared:jar:10.1.0-Xpress, org.forgerock.openam:openam-federation-library:jar:10.1.0-Xpress, org.forgerock.openam:openam-clientsdk:jar:10.1.0-Xpress: Failure to find org.forgerock.openam:openam-core:jar:10.1.0-Xpress in http://nexus.example.private:8081/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of nexus has elapsed or updates are forced -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles: 
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

EDIT 2:

[INFO] ------------------------------------------------------------------------
[INFO] Building OpenAMExample 0.0.1-SNAPSHOT
 [INFO] ------------------------------------------------------------------------
[WARNING] The POM for com.sun.web.ui:cc_zh_HK:jar:2008-08-08 is missing, no dependency information available
Downloading: http://nexus.example.private:8081/content/groups/public/com/sun/web/ui/cc_zh_TW/2008-08-08/cc_zh_TW-2008-08-08.pom

[WARNING] The POM for com.sun.web.ui:cc_zh_TW:jar:2008-08-08 is missing, no dependency information available
Downloading: http://nexus.example.private:8081/content/groups/public/external/esapiport/2009-26-07/esapiport-2009-26-07.pom

 [WARNING] The POM for external:esapiport:jar:2009-26-07 is missing, no dependency information available
Downloading: http://nexus.example.private:8081/content/groups/public/external/sleepycat-je/2011-04-07/sleepycat-je-2011-04-07.pom

[WARNING] The POM for external:webservices-rt:jar:2009-29-07 is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 42.038s
[INFO] Finished at: Mon Aug 05 16:31:52 BST 2013
[INFO] Final Memory: 5M/15M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project OpenAMExample: Could not resolve dependencies for project com.webchannel.example:OpenAMExample:jar:0.0.1-SNAPSHOT: Failed to collect dependencies for [org.forgerock.openam:openam-core:jar:10.1.0-Xpress (compile), org.forgerock.openam:openam-shared:jar:10.1.0-Xpress (compile), org.forgerock.openam:openam-federation-library:jar:10.1.0-Xpress (compile), org.forgerock.openam:openam-clientsdk:jar:10.1.0-Xpress (compile), junit:junit:jar:3.8.1 (test)]: Failed to read artifact descriptor for org.forgerock.opendj:opendj-server:jar:2.4.6: Could not find artifact org.forgerock.opendj:opendj-project:pom:3.0.0-SNAPSHOT in nexus (http://nexus.example.private:8081/content/groups/public) -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

Answers


it says was cached in the local repository

Go to $HOME/.m2/repository/org/ and remove forgerock directory and try again

you might had a connection error or something like that

another way is to try right click > maven > maven update if you use m2e and check force updating release


the dependency of OpenSSOclientsdk, at the moment, is not found in any maven repository. Therefore, you must include in your local repository:

{dir maven repo}/com/sun/identity/OpenSSOclientsdk/8.0/OpenSSOclientsdk-8.0.jar.

Then, you can execute

$ mvn install

And the provider will be located in

{dir maven repo}/com/sun/identity/provider/springsecurity/0.1/springsecurity-0.1.jar

to be used in maven projects. (See more details in http://maven.apache.org)


Need Your Help

SKMaps crashes when add SKViaPoint

ios xcode skmaps

I'm using SKMaps to simulate custom routes. It was working fine with navigating a point to another point, I mean use start and destination only: