Piwik: PHP upgrade broke Piwik

I have upgraded PHP from 5.3.7 to 5.4.4 on my Debian 6 (Squeeze) system. After this upgrade Piwik stopped working. The following error occurs:

The string to escape is not a valid UTF-8 string in "@CoreHome/getDefaultIndexView.twig".

I tried Googling, but could not get any solution. Anyone knows how to fix this error?

Thanks, Anji

Answers


If you have issues with the update process, download Piwik manually and replace it with your installed system.

For security reasons, take a backup from your database and your config file.


Need Your Help

CodeIgniter image watermark returns blank image when using dynamic output

php jquery codeigniter gd

I'm using jquery to post data to a controller function which watermarks an image located on the server and dynamically posts it back. The watermark function works when I'm not using dynamic output,...

Is there a way to have a random image appear every time an item spawns? (Objective-C)

ios objective-c sprite-kit

I'm working on a sprite-kit game for IOS. In my game, I have pieces of debris spawn every 5 seconds, then move towards the player, like obstacles. I made a series of images for the debris I wanted...