What's the latest version of build-helper-maven-plugin that requires JDK 1.6?

The latest version of the Build Helper Maven plugin (1.10 at the moment) requires Java 1.7, which broke my build. The plugin documentation page only shows Java version requirement for the latest version.

Answers


Looking at Build Helper Maven Plugin versions, here

  • version 1.9.1 points to parent POM org.codehaus.mojo.mojo-parent version 33, which still sets its Java target at 1.5 (via the property mojo.java.target).

  • version 1.10 points to parent POM org.codehaus.mojo.mojo-parent version 38, which sets its Java target at 1.7

Hence, Build Helper Maven Plugin 1.9.1 is the latest version compatible with Java 6. From that version on, Java 7 is the default target.


Need Your Help

Running sbt with Wartremover

scala plugins sbt

I'd like to check the code of my whole project with wartremover and sbt.