Unable to associate project with a runtime server in eclipse IDE

I had created a dynamic web project. AS of now it has a jsp file which am trying to run. When I tried to associate the project with a specific runtime(tomcat 6.0), it is not happening.

I right clicked on the project/properties/Targeted Runtimes. It doesn't show any runtimes(I have added tomcat 6.0 in servers). When I click the checkbox 'Show all runtimes', everything comes in disabled mode.

What could be the problem ?

Attached screenshot of the problem.

Update: I even tried to create a new runtime and associate it with the project( project/properties/Targeted Runtimes/new). Even the newly created runtime is getting disabled and am unable to associate it with the project.

Answers


To add a project to a runtime you must have a match between your project and your runtime; you have to check:

  • project facet: to run on tomcat it must be a Dynamic Web Project
  • java version: you can't run for example a java 7 project on a java 6 runtime
  • web project version: you can't run a project that doesn't match the Java EE version deployable in the runtime

Once you've validated the match between your project and the runtime, you need the project to target the runtime, as follows:

  1. Open the project in Package Explorer, Project Explorer, or Navigator.
  2. Right-click on the project, and select "Properties".
  3. Click on "Targeted Runtimes" in the properties window.
  4. Select the checkbox of the validated runtime that is to be targeted.
  5. Confirm by clicking "OK".

The new runtime will be associated with that project. If a runtime that you want to select is not displayed or is disabled, you may need to uninstall one or more of the currently installed project facets. This can be done within the same Properties dialogue.


This is what worked for me. I'm just posting my method because it might help somebody else.

  1. Right-click on project
  2. Click on Properties
  3. Go to Project Facets
  4. Uncheck Dynamic Web Module checkbox
  5. Click on Runtimes in the tabs on the right. Apache Tomcat vX.x should be available now
  6. Check Apache Tomcat vX.x
  7. Click Apply and Close
  8. Repeat the previous steps 1-3
  9. Check Dynamic Web Module checkbox
  10. Apache Tomcat vX.x under Runtimes should still be enabled
  11. Click Apply and Close

I know it's already answered question, but I like to share my solution with new users if I can help..

For me the problem was because of the Dynamic wen Project version, 3.0 work with java 1.7 ( I was using 3.1) . If it didn't work you can access .settings folder in your project, org.eclipse.wst.common.project.facet.core.xml file and set the version that you need.

<installed facet="jst.web" version="3.0"/>

Hope I can help new users


I have Found a fix for this problem. Go to Preferences and Check your Targeted runtime, If No Runtime is displayed you can Configure it through Feacts. Select Dinamic Web module to 3.0 or 3.1

You can Also refer to this Video for Detailed Explanation. : https://youtu.be/0W6s0hXbmNE


Need Your Help

google Cloud Messaging Push notification

android push-notification google-cloud-messaging

Can I use POSTMAN client on Google Chrome to send payload message to GCM server for testing purpose.