No results and no log information in Apache JMeter

I have set up a class extending AbstractJavaSamplerClientcontaining a setupTest, runTest and getDefaultParameters method, all written accordingly to the jMeter's templates and online examples.

Have added a Logger, tried setting it up normally (LoggingManager.getLoggerForClass();) and using super as well (super.getLogger();) and added multiple Logger.info and Logger.error

I'm using a Java request and giving a Jar containing my classes have completed the user.properties with the classpath. The right class is selected when running the tests.

When I run my tests, no custom logs appear. No error either. And I'm getting this:

2016/02/03 13:34:42 INFO  - jmeter.engine.StandardJMeterEngine: Running the test! 
2016/02/03 13:34:42 INFO  - jmeter.samplers.SampleEvent: List of sample_variables: [] 
2016/02/03 13:34:42 INFO  - jmeter.gui.util.JMeterMenuBar: setRunning(true,*local*) 
2016/02/03 13:34:42 INFO  - jmeter.engine.StandardJMeterEngine: Starting ThreadGroup: 1 : Group Test
2016/02/03 13:34:42 INFO  - jmeter.engine.StandardJMeterEngine: Starting 1 threads for group Group Test. 
2016/02/03 13:34:42 INFO  - jmeter.engine.StandardJMeterEngine: Thread will start next loop on error 
2016/02/03 13:34:42 INFO  - jmeter.threads.ThreadGroup: Starting thread group number 1 threads 1 ramp-up 1 perThread 1000.0 delayedStart=false 
2016/02/03 13:34:42 INFO  - jmeter.threads.ThreadGroup: Started thread group number 1 
2016/02/03 13:34:42 INFO  - jmeter.engine.StandardJMeterEngine: All thread groups have been started 
2016/02/03 13:34:42 INFO  - jmeter.threads.JMeterThread: Thread started: Group Test 1-1 
2016/02/03 13:34:42 INFO  - jmeter.threads.JMeterThread: Thread is done: Group Test 1-1 
2016/02/03 13:34:42 INFO  - jmeter.threads.JMeterThread: Thread finished: Group Test 1-1 
2016/02/03 13:34:42 INFO  - jmeter.engine.StandardJMeterEngine: Notifying test listeners of end of test 
2016/02/03 13:34:42 INFO  - jmeter.gui.util.JMeterMenuBar: setRunning(false,*local*) 

I've checked the user.properties and the logs are written to jmeter.log I feel like my class is not even tested since the logs are not displaying anything beside "Starting/Done/Finshed Thread".

When I add a result tree or any other result thread, it stays empty.

What could be set up wrong here?

EDIT: Didn't use the right JAVa request (Configurations>Default Java Request != Single Java Request). From that point I saw I had an error with my Jonas thus not connecting and explaining the non existent results.

Answers


As per example given in WebSocket Testing With Apache JMeter article:

  1. Necessary imports:

    import org.apache.jorphan.logging.LoggingManager;
    import org.apache.log.Logger;
    
  2. Initialization:

    private static final Logger log = LoggingManager.getLoggerForClass();
    
  3. Usage:

    log.info("your log message");
    log.error("your error message", exception);
    

Need Your Help

how to test in case of eventual consistency?

python google-app-engine

i have an app ( google app engine + high replication datastore ) which was not using eventual consistency ( high replication ) up till now and all my test worked perfectly.

Android graphical layout has a default actionbar shown in some cases

android xml android-actionbar graphical-layout-editor

In the xml graphical layout of my android application there is a actionbar shown in one of my android studio projects and not in others. Out of curiosity i would like to know the reason behind this...