An unknown error occurred when I was trying to use an iPad for development

I was trying to test my app on a new iPad to see if Retina support is working.

Like anyother devices I used for development, I attached the device and pressed "Use For Development" is XCode Organizer.

The process started but a few seconds later the progress bar went away and I received this error message : " An Unknown Error Occurred "

I registered its UDID in devices section manually and the provisioning profile is successfully installed on the device but there still is a yellow dot in front of iPad's name in organizer and the device is not appearing in the iOS Devices list ( so that I cannot run my app on it ).

I tried anything came to my mind but nothing worked out :(

Any ideas ?


Additional Info :

  • XCode version : 4.4.1
  • iOS SDK version : 5.1
  • Minimum Deployment Target : 5.0
  • Device iOS Version : 5.1.1 (9B206)
  • Device type : 3rd Gen New iPad ( Wifi + 4G )
  • Intel Based Mac : Mac Pro With 2 x 2.26 GHz Quad-Core Intel Xeon
  • OS Version : OS X Mountain Lion 10.8 (12A269)

Answers


Try disconnecting / reconnecting the iPad, quit and restart XCode, ... Sometimes it just won't work and restarting everything solves it !


This has happened to me a lot when I'm plugged in via the Apple USB keyboard (that has two USB ports underneath).

If you plug in more than one thing in that keyboard, like two iPhones, it won't be able to deliver enough power to both, and you start getting intermittent disconnections.

Solution: Plug in directly to the Mac.


One time this happened to me and it seemed my iCloud account on my device was not logged in. This was due to a password change I had done. Once I signed back in with the proper password the app seemed to build to the device just fine. :-)


In my case, after trying everything (restart of Ipad, XCode, imac), I found out the issue was being caused by the same app still running in the background of the Ipad from a previous run. I just had to dismiss the app from Ipad and all got fixed.


Not a duplicate, but OS X, XCode, and IOS often fall on their swords because of code signing and caching fails, see if anything here helps: Error : failed to launch, when running on ipad


I was able to fix this issue by changing the signing identity from one team to another, then back to the original team.


You can use xcode->windows->devices and watch the device log to get more detail about "An unknown error occurred",you will get something like this:

  • 0x16e12f000 +[MICodeSigningVerifier _validateSignatureAndCopyInfoForURL:withOptions:error:]: 142: Failed to verify code signature of /private/var/mobile/Library/Caches/com.apple.mobile.installd.staging/temp.L5Dvt0/extracted/Payload/Xxx.app/PlugIns/packetTunnel.appex : 0xe8008001 (An unknown error has occurred.)

I have seen "An unknown error occurred" at follow conditions and fix it by correcting the code:

  • I write @interface with a class,and forget @implementation with that class name in an extension target.
  • There is no code in one target of my project.

I got this error when trying to install a 1GB app on a device with only 300MB left. I did not expect it to be an issue since the app was already installed on the device from iTunes, and I was just installing a local build to overwrite it, but I got this error repeatedly until I uninstalled the copy from the store. After that, it worked just fine.


I could only get this to work by reconnecting the phone then following through with the iCloud welcome screens on my laptop.


I found that because my iphone had gone flat and I had been charging it, the phone needed to be opened with the pin first to allow Xcode to connect


Happened for me when iTunes was open in the background. Closing iTunes and Xcode, then re-opening Xcode worked for me.


I had same error message when i instaled new pods (CocoaPods). I was able to fix this problem by removing latest added pods from my project.


I face with same trouble regularly: iPhone restart fixes it every time


Need Your Help

.htm vs .html

html naming-conventions file-extension

Which extension should I choose for my HTML files and why?

How to select the rows with maximum values in each group with dplyr?

r dplyr plyr greatest-n-per-group

I would like to select a row with maximum value in each group with dplyr.